#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE) # start DEFINE block" & @CRLF & _
" # condition1" & @CRLF & _
" (?<condition1>(?!(?:^__)))" & @CRLF & _
" # condition2" & @CRLF & _
" (?<condition2>(?!.*thumb))" & @CRLF & _
" # allowed extensions " & @CRLF & _
" (?<ext>\.(?:gif|png|jpe?g)$)" & @CRLF & _
")" & @CRLF & _
"^(?&condition1)(?&condition2).+(?&ext)$"
Local $sString = "test.png" & @CRLF & _
"__somefile.png" & @CRLF & _
"_somefile.gif" & @CRLF & _
"this_one_contains_athumb.jpg" & @CRLF & _
"wrong_thmb.jpeg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")