using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE) # start DEFINE block
# condition1
(?<condition1>(?!(?:^__)))
# condition2
(?<condition2>(?!.*thumb))
# allowed extensions
(?<ext>\.(?:gif|png|jpe?g)$)
)
^(?&condition1)(?&condition2).+(?&ext)$";
string input = @"test.png
__somefile.png
_somefile.gif
this_one_contains_athumb.jpg
wrong_thmb.jpeg";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}