// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?(DEFINE) # start DEFINE block
# condition1
(?<condition1>(?!(?:^__)))
# condition2
(?<condition2>(?!.*thumb))
# allowed extensions
(?<ext>\.(?:gif|png|jpe?g)$)
)
^(?&condition1)(?&condition2).+(?&ext)$").unwrap();
let string = "test.png
__somefile.png
_somefile.gif
this_one_contains_athumb.jpg
wrong_thmb.jpeg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}