$re = '~(?(DEFINE) # start DEFINE block
# condition1
(?<condition1>(?!(?:^__)))
# condition2
(?<condition2>(?!.*thumb))
# allowed extensions
(?<ext>\.(?:gif|png|jpe?g)$)
)
^(?&condition1)(?&condition2).+(?&ext)$~mx';
$str = 'test.png
__somefile.png
_somefile.gif
this_one_contains_athumb.jpg
wrong_thmb.jpeg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);