import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE) # start DEFINE block\n"
+ " # condition1\n"
+ " (?<condition1>(?!(?:^__)))\n"
+ " # condition2\n"
+ " (?<condition2>(?!.*thumb))\n"
+ " # allowed extensions \n"
+ " (?<ext>\\.(?:gif|png|jpe?g)$)\n"
+ ")\n"
+ "^(?&condition1)(?&condition2).+(?&ext)$";
final String string = "test.png\n"
+ "__somefile.png\n"
+ "_somefile.gif\n"
+ "this_one_contains_athumb.jpg\n"
+ "wrong_thmb.jpeg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}