# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE) # start DEFINE block
# condition1
(?<condition1>(?!(?:^__)))
# condition2
(?<condition2>(?!.*thumb))
# allowed extensions
(?<ext>\.(?:gif|png|jpe?g)$)
)
^(?&condition1)(?&condition2).+(?&ext)$
"""
test_str = ("test.png\n"
"__somefile.png\n"
"_somefile.gif\n"
"this_one_contains_athumb.jpg\n"
"wrong_thmb.jpeg")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.