import re
regex = re.compile(r"^[a-z A-Z]+\d{0,5} ?[a-zA-Z]?", flags=re.MULTILINE)
test_str = ("Oslo gate 20\n"
"Oslo gate 39a\n"
"Oslo gate 39 a\n"
"Oslo Gate\n"
"Oslo\n"
"30\n"
"Oslo gate49a\n"
" Oslo gate 39a\n"
"Oslo gate 34a, leil. H0205\n"
"leil. H0205, Oslo gate 34a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")