re = /^[a-z A-Z]+\d{0,5} ?[a-zA-Z]?/m
str = 'Oslo gate 20
Oslo gate 39a
Oslo gate 39 a
Oslo Gate
Oslo
30
Oslo gate49a
Oslo gate 39a
Oslo gate 34a, leil. H0205
leil. H0205, Oslo gate 34a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end