#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<textarea([^>]+)[>]([^<]+[^t]+[^e]+[^x]+[^t]+[^a]+[^r]+[^e]+[^a]+[^>]|.*)<\/textarea>"
Local $sString = "<h2>Textarea com quebra de linha e html</h2>" & @CRLF & _
"" & @CRLF & _
"<p>" & @CRLF & _
" <textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">" & @CRLF & _
" <p>5051950 á</p>" & @CRLF & _
" </textarea>" & @CRLF & _
"</p>" & @CRLF & _
"" & @CRLF & _
"<h2>Textarea com texto</h2>" & @CRLF & _
"" & @CRLF & _
"<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">teste á teste teste teste teste</textarea></p>" & @CRLF & _
"" & @CRLF & _
"<h2>Textarea com um item</h2>" & @CRLF & _
"" & @CRLF & _
"<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">e</textarea></p>" & @CRLF & _
"" & @CRLF & _
"<h2>Textarea vazio</h2>" & @CRLF & _
"" & @CRLF & _
"<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>" & @CRLF & _
"" & @CRLF & _
"<h2>Textarea invalido</h2>" & @CRLF & _
"" & @CRLF & _
"<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">é<textarea></p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")