// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<textarea([^>]+)[>]([^<]+[^t]+[^e]+[^x]+[^t]+[^a]+[^r]+[^e]+[^a]+[^>]|.*)<\/textarea>").unwrap();
let string = "<h2>Textarea com quebra de linha e html</h2>
<p>
<textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">
<p>5051950 á</p>
</textarea>
</p>
<h2>Textarea com texto</h2>
<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">teste á teste teste teste teste</textarea></p>
<h2>Textarea com um item</h2>
<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">e</textarea></p>
<h2>Textarea vazio</h2>
<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\"></textarea></p>
<h2>Textarea invalido</h2>
<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">é<textarea></p>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}