const regex = /<textarea([^>]+)[>]([^<]+[^t]+[^e]+[^x]+[^t]+[^a]+[^r]+[^e]+[^a]+[^>]|.*)<\/textarea>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<textarea([^>]+)[>]([^<]+[^t]+[^e]+[^x]+[^t]+[^a]+[^r]+[^e]+[^a]+[^>]|.*)<\\\/textarea>', 'g')
const str = `<h2>Textarea com quebra de linha e html</h2>
<p>
<textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
<p>5051950 á</p>
</textarea>
</p>
<h2>Textarea com texto</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">teste á teste teste teste teste</textarea></p>
<h2>Textarea com um item</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">e</textarea></p>
<h2>Textarea vazio</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>
<h2>Textarea invalido</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">é<textarea></p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}