use strict;
my $str = '<h2>Textarea com quebra de linha e html</h2>
<p>
<textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
<p>5051950 á</p>
</textarea>
</p>
<h2>Textarea com texto</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">teste á teste teste teste teste</textarea></p>
<h2>Textarea com um item</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">e</textarea></p>
<h2>Textarea vazio</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>
<h2>Textarea invalido</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">é<textarea></p>
';
my $regex = qr/<textarea([^>]+)[>]([^<]+[^t]+[^e]+[^x]+[^t]+[^a]+[^r]+[^e]+[^a]+[^>]|.*)<\/textarea>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}