$re = '/<textarea([^>]+)[>]([^<]+[^t]+[^e]+[^x]+[^t]+[^a]+[^r]+[^e]+[^a]+[^>]|.*)<\/textarea>/';
$str = '<h2>Textarea com quebra de linha e html</h2>
<p>
<textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
<p>5051950 á</p>
</textarea>
</p>
<h2>Textarea com texto</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">teste á teste teste teste teste</textarea></p>
<h2>Textarea com um item</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">e</textarea></p>
<h2>Textarea vazio</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>
<h2>Textarea invalido</h2>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">é<textarea></p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);