import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<textarea([^>]+)[>]([^<]+[^t]+[^e]+[^x]+[^t]+[^a]+[^r]+[^e]+[^a]+[^>]|.*)<\\/textarea>";
final String string = "<h2>Textarea com quebra de linha e html</h2>\n\n"
+ "<p>\n"
+ " <textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">\n"
+ " <p>5051950 á</p>\n"
+ " </textarea>\n"
+ "</p>\n\n"
+ "<h2>Textarea com texto</h2>\n\n"
+ "<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">teste á teste teste teste teste</textarea></p>\n\n"
+ "<h2>Textarea com um item</h2>\n\n"
+ "<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">e</textarea></p>\n\n"
+ "<h2>Textarea vazio</h2>\n\n"
+ "<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\"></textarea></p>\n\n"
+ "<h2>Textarea invalido</h2>\n\n"
+ "<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">é<textarea></p>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}