package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^C]*CATEG="([^"]+)"[^>]*>([^<]+)`)
var str = `História do RFID A tecnologia de <EM ID="hub-30518" CATEG="PESSOA">RFID </EM>tem suas raÃzes nos sistemas de radares`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}