import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^C]*CATEG=\"([^\"]+)\"[^>]*>([^<]+)";
final String string = "História do RFID A tecnologia de <EM ID=\"hub-30518\" CATEG=\"PESSOA\">RFID </EM>tem suas raÃzes nos sistemas de radares";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}