$re = '/<[^C]*CATEG="([^"]+)"[^>]*>([^<]+)/';
$str = 'História do RFID A tecnologia de <EM ID="hub-30518" CATEG="PESSOA">RFID </EM>tem suas raÃzes nos sistemas de radares';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);