re = /<[^C]*CATEG="([^"]+)"[^>]*>([^<]+)/
str = 'História do RFID A tecnologia de <EM ID="hub-30518" CATEG="PESSOA">RFID </EM>tem suas raÃzes nos sistemas de radares'
# Print the match result
str.match(re) do |match|
puts match.to_s
end