const regex = /<[^C]*CATEG="([^"]+)"[^>]*>([^<]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^C]*CATEG="([^"]+)"[^>]*>([^<]+)', '')
const str = `História do RFID A tecnologia de <EM ID="hub-30518" CATEG="PESSOA">RFID </EM>tem suas raÃzes nos sistemas de radares`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}