#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/pp/dc/dc[123]/h([1-9]{1,2}|100)$"
Local $sString = "/pp/dc/dc1/h1" & @CRLF & _
"..." & @CRLF & _
"/pp/dc/dc1/h100" & @CRLF & _
"" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"/pp/dc/dc2/h1" & @CRLF & _
"..." & @CRLF & _
"/pp/dc/dc2/h100" & @CRLF & _
"" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"/pp/dc/dc3/h1" & @CRLF & _
"..." & @CRLF & _
"/pp/dc/dc3/h100" & @CRLF & _
"" & @CRLF & _
"/pp/dc/dc3/h101" & @CRLF & _
"" & @CRLF & _
"/pp/dc/dc3/h155" & @CRLF & _
"" & @CRLF & _
"/pp/dc/dc2/h10/pro" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")