import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/pp/dc/dc[123]/h([1-9]{1,2}|100)$";
final String string = "/pp/dc/dc1/h1\n"
+ "...\n"
+ "/pp/dc/dc1/h100\n\n"
+ "or\n\n"
+ "/pp/dc/dc2/h1\n"
+ "...\n"
+ "/pp/dc/dc2/h100\n\n"
+ "or\n\n"
+ "/pp/dc/dc3/h1\n"
+ "...\n"
+ "/pp/dc/dc3/h100\n\n"
+ "/pp/dc/dc3/h101\n\n"
+ "/pp/dc/dc3/h155\n\n"
+ "/pp/dc/dc2/h10/pro\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}