package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/pp/dc/dc[123]/h([1-9]{1,2}|100)$`)
var str = `/pp/dc/dc1/h1
...
/pp/dc/dc1/h100
or
/pp/dc/dc2/h1
...
/pp/dc/dc2/h100
or
/pp/dc/dc3/h1
...
/pp/dc/dc3/h100
/pp/dc/dc3/h101
/pp/dc/dc3/h155
/pp/dc/dc2/h10/pro
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}