import re
regex = re.compile(r"^/pp/dc/dc[123]/h([1-9]{1,2}|100)$", flags=re.MULTILINE)
test_str = ("/pp/dc/dc1/h1\n"
"...\n"
"/pp/dc/dc1/h100\n\n"
"or\n\n"
"/pp/dc/dc2/h1\n"
"...\n"
"/pp/dc/dc2/h100\n\n"
"or\n\n"
"/pp/dc/dc3/h1\n"
"...\n"
"/pp/dc/dc3/h100\n\n"
"/pp/dc/dc3/h101\n\n"
"/pp/dc/dc3/h155\n\n"
"/pp/dc/dc2/h10/pro\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")