re = /^\/pp\/dc\/dc[123]\/h([1-9]{1,2}|100)$/m
str = '/pp/dc/dc1/h1
...
/pp/dc/dc1/h100
or
/pp/dc/dc2/h1
...
/pp/dc/dc2/h100
or
/pp/dc/dc3/h1
...
/pp/dc/dc3/h100
/pp/dc/dc3/h101
/pp/dc/dc3/h155
/pp/dc/dc2/h10/pro
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end