#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*?) contains (.*?)\s*(?:([|&])\3|$)\s*"
Local $sString = "huile contains rgbgrbrb9gr && huile contains fcecec" & @CRLF & _
"oil & other contains oil & blah" & @CRLF & _
"huile contains test2 || huile contains test4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")