re = /(.*?) contains (.*?)\s*(?:([|&])\3|$)\s*/m
str = 'huile contains rgbgrbrb9gr && huile contains fcecec
oil & other contains oil & blah
huile contains test2 || huile contains test4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end