import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?) contains (.*?)\\s*(?:([|&])\\3|$)\\s*";
final String string = "huile contains rgbgrbrb9gr && huile contains fcecec\n"
+ "oil & other contains oil & blah\n"
+ "huile contains test2 || huile contains test4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}