using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^name=\""([^\""]*)\"",value=(\[([^\]]+)\]|\""[^\""]+\"")(.*)";
string substitution = @"\1:\2";
string input = @"name=""Building"",value=""Southwest"",descendants_action=""success"",operation=""OVERRIDE""
name=""Building"",value=[""Northeast"",""Northwest""],descendants_action=""failure"",operation=""OVERRIDE""
name=""Building"",value=""Southeast"",descendants_action=""success"",operation=""OVERRIDE""
name=""Building"",value=""Northwest""
name=""Building"",value=""Northwest"",operation=""OVERRIDE""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}