re = /^name=\"([^\"]*)\",value=(\[([^\]]+)\]|\"[^\"]+\")(.*)/m
str = 'name="Building",value="Southwest",descendants_action="success",operation="OVERRIDE"
name="Building",value=["Northeast","Northwest"],descendants_action="failure",operation="OVERRIDE"
name="Building",value="Southeast",descendants_action="success",operation="OVERRIDE"
name="Building",value="Northwest"
name="Building",value="Northwest",operation="OVERRIDE"'
subst = '\\1:\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result