import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^name=\\\"([^\\\"]*)\\\",value=(\\[([^\\]]+)\\]|\\\"[^\\\"]+\\\")(.*)";
final String string = "name=\"Building\",value=\"Southwest\",descendants_action=\"success\",operation=\"OVERRIDE\"\n"
+ "name=\"Building\",value=[\"Northeast\",\"Northwest\"],descendants_action=\"failure\",operation=\"OVERRIDE\"\n"
+ "name=\"Building\",value=\"Southeast\",descendants_action=\"success\",operation=\"OVERRIDE\"\n"
+ "name=\"Building\",value=\"Northwest\"\n"
+ "name=\"Building\",value=\"Northwest\",operation=\"OVERRIDE\"";
final String subst = "\\1:\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}