const regex = /^name=\"([^\"]*)\",value=(\[([^\]]+)\]|\"[^\"]+\")(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^name=\\"([^\\"]*)\\",value=(\\[([^\\]]+)\\]|\\"[^\\"]+\\")(.*)', 'gm')
const str = `name="Building",value="Southwest",descendants_action="success",operation="OVERRIDE"
name="Building",value=["Northeast","Northwest"],descendants_action="failure",operation="OVERRIDE"
name="Building",value="Southeast",descendants_action="success",operation="OVERRIDE"
name="Building",value="Northwest"
name="Building",value="Northwest",operation="OVERRIDE"`;
const subst = `\1:\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);