use strict;
my $str = 'name="Building",value="Southwest",descendants_action="success",operation="OVERRIDE"
name="Building",value=["Northeast","Northwest"],descendants_action="failure",operation="OVERRIDE"
name="Building",value="Southeast",descendants_action="success",operation="OVERRIDE"
name="Building",value="Northwest"
name="Building",value="Northwest",operation="OVERRIDE"';
my $regex = qr/^name=\"([^\"]*)\",value=(\[([^\]]+)\]|\"[^\"]+\")(.*)/mp;
my $subst = '\\1:\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";