// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^name=\"([^\"]*)\",value=(\[([^\]]+)\]|\"[^\"]+\")(.*)"#).unwrap();
let string = "name=\"Building\",value=\"Southwest\",descendants_action=\"success\",operation=\"OVERRIDE\"
name=\"Building\",value=[\"Northeast\",\"Northwest\"],descendants_action=\"failure\",operation=\"OVERRIDE\"
name=\"Building\",value=\"Southeast\",descendants_action=\"success\",operation=\"OVERRIDE\"
name=\"Building\",value=\"Northwest\"
name=\"Building\",value=\"Northwest\",operation=\"OVERRIDE\"";
let substitution = "\\1:\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}