#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<i class="(?:.*\s)?([^"]*)"><\/i>"
Local $sString = "function myFunction() {" & @CRLF & _
"var str = '<i class="fa fa-edit"></i>'; " & @CRLF & _
"var res = str.match(/'fa-'*/);" & @CRLF & _
"return res;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")