import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<i class=\"(?:.*\\s)?([^\"]*)\"><\\/i>";
final String string = "function myFunction() {\n"
+ "var str = '<i class=\"fa fa-edit\"></i>'; \n"
+ "var res = str.match(/'fa-'*/);\n"
+ "return res;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}