package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<i class="(?:.*\s)?([^"]*)"><\/i>`)
var str = `function myFunction() {
var str = '<i class="fa fa-edit"></i>';
var res = str.match(/'fa-'*/);
return res;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}