using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<i class=""(?:.*\s)?([^""]*)""><\/i>";
string input = @"function myFunction() {
var str = '<i class=""fa fa-edit""></i>';
var res = str.match(/'fa-'*/);
return res;
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}