re = /<i class="(?:.*\s)?([^"]*)"><\/i>/m
str = 'function myFunction() {
var str = \'<i class="fa fa-edit"></i>\';
var res = str.match(/\'fa-\'*/);
return res;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end