#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<Field(?:Array)?(?=(?:[^>"']|"[^"]*"|'[^']*')*?\sname\s*=\s*(?:(['"])\s*document\s*\1))\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+\/>"
Local $sString = " <Field" & @CRLF & _
" name="amount"" & @CRLF & _
" component={FormField}" & @CRLF & _
" label={t('form.amount')}" & @CRLF & _
" />" & @CRLF & _
" <Field" & @CRLF & _
" name="datereception"" & @CRLF & _
" component={FormField}" & @CRLF & _
" label={t('form.datereception')}" & @CRLF & _
" />" & @CRLF & _
" <Field" & @CRLF & _
" component={FormField}" & @CRLF & _
" name="document"" & @CRLF & _
" typeInput="selectAutocomplete"" & @CRLF & _
" />" & @CRLF & _
" <Field" & @CRLF & _
" name="datedeferred"" & @CRLF & _
" component={FormField}" & @CRLF & _
" label={t('form.datedeferred')}" & @CRLF & _
" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")