using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Field(?:Array)?(?=(?:[^>""']|""[^""]*""|'[^']*')*?\sname\s*=\s*(?:(['""])\s*document\s*\1))\s+(?:""[\S\s]*?""|'[\S\s]*?'|[^>]*?)+\/>";
string input = @" <Field
name=""amount""
component={FormField}
label={t('form.amount')}
/>
<Field
name=""datereception""
component={FormField}
label={t('form.datereception')}
/>
<Field
component={FormField}
name=""document""
typeInput=""selectAutocomplete""
/>
<Field
name=""datedeferred""
component={FormField}
label={t('form.datedeferred')}
/>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}