re = /<Field(?:Array)?(?=(?:[^>"']|"[^"]*"|'[^']*')*?\sname\s*=\s*(?:(['"])\s*document\s*\1))\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+\/>/
str = ' <Field
name="amount"
component={FormField}
label={t(\'form.amount\')}
/>
<Field
name="datereception"
component={FormField}
label={t(\'form.datereception\')}
/>
<Field
component={FormField}
name="document"
typeInput="selectAutocomplete"
/>
<Field
name="datedeferred"
component={FormField}
label={t(\'form.datedeferred\')}
/>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end