const regex = /<Field(?:Array)?(?=(?:[^>"']|"[^"]*"|'[^']*')*?\sname\s*=\s*(?:(['"])\s*document\s*\1))\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+\/>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Field(?:Array)?(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\\sname\\s*=\\s*(?:([\'"])\\s*document\\s*\\1))\\s+(?:"[\\S\\s]*?"|\'[\\S\\s]*?\'|[^>]*?)+\\\/>', '')
const str = ` <Field
name="amount"
component={FormField}
label={t('form.amount')}
/>
<Field
name="datereception"
component={FormField}
label={t('form.datereception')}
/>
<Field
component={FormField}
name="document"
typeInput="selectAutocomplete"
/>
<Field
name="datedeferred"
component={FormField}
label={t('form.datedeferred')}
/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}