using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Power"":(?P<_power>[\d.]+).*""Voltage"":(?P<_voltage>[\d.]+).*""Current"":(?P<_current>[\d.]+)";
string input = @"{""Time"":""2021-06-27T17:42:26"",""ENERGY"":{""TotalStartTime"":""2021-01-16T13:12:08"",""Total"":56.040,""Yesterday"":0.923,""Today"":0.536,""Period"":0,""Power"":6,""ApparentPower"":21,""ReactivePower"":20,""Factor"":0.29,""Voltage"":233,""Current"":0.088}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}