$re = '/"Power":(?P<_power>[\d.]+).*"Voltage":(?P<_voltage>[\d.]+).*"Current":(?P<_current>[\d.]+)/m';
$str = '{"Time":"2021-06-27T17:42:26","ENERGY":{"TotalStartTime":"2021-01-16T13:12:08","Total":56.040,"Yesterday":0.923,"Today":0.536,"Period":0,"Power":6,"ApparentPower":21,"ReactivePower":20,"Factor":0.29,"Voltage":233,"Current":0.088}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);