// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"Power":(?P<_power>[\d.]+).*"Voltage":(?P<_voltage>[\d.]+).*"Current":(?P<_current>[\d.]+)"#).unwrap();
let string = "{\"Time\":\"2021-06-27T17:42:26\",\"ENERGY\":{\"TotalStartTime\":\"2021-01-16T13:12:08\",\"Total\":56.040,\"Yesterday\":0.923,\"Today\":0.536,\"Period\":0,\"Power\":6,\"ApparentPower\":21,\"ReactivePower\":20,\"Factor\":0.29,\"Voltage\":233,\"Current\":0.088}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}