const regex = /"Power":(?P<_power>[\d.]+).*"Voltage":(?P<_voltage>[\d.]+).*"Current":(?P<_current>[\d.]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"Power":(?P<_power>[\\d.]+).*"Voltage":(?P<_voltage>[\\d.]+).*"Current":(?P<_current>[\\d.]+)', 'gm')
const str = `{"Time":"2021-06-27T17:42:26","ENERGY":{"TotalStartTime":"2021-01-16T13:12:08","Total":56.040,"Yesterday":0.923,"Today":0.536,"Period":0,"Power":6,"ApparentPower":21,"ReactivePower":20,"Factor":0.29,"Voltage":233,"Current":0.088}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}