import re
regex = re.compile(r"\"Power\":(?P<_power>[\d.]+).*\"Voltage\":(?P<_voltage>[\d.]+).*\"Current\":(?P<_current>[\d.]+)", flags=re.MULTILINE)
test_str = "{\"Time\":\"2021-06-27T17:42:26\",\"ENERGY\":{\"TotalStartTime\":\"2021-01-16T13:12:08\",\"Total\":56.040,\"Yesterday\":0.923,\"Today\":0.536,\"Period\":0,\"Power\":6,\"ApparentPower\":21,\"ReactivePower\":20,\"Factor\":0.29,\"Voltage\":233,\"Current\":0.088}}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")