import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"Power\":(?P<_power>[\\d.]+).*\"Voltage\":(?P<_voltage>[\\d.]+).*\"Current\":(?P<_current>[\\d.]+)";
final String string = "{\"Time\":\"2021-06-27T17:42:26\",\"ENERGY\":{\"TotalStartTime\":\"2021-01-16T13:12:08\",\"Total\":56.040,\"Yesterday\":0.923,\"Today\":0.536,\"Period\":0,\"Power\":6,\"ApparentPower\":21,\"ReactivePower\":20,\"Factor\":0.29,\"Voltage\":233,\"Current\":0.088}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}