#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z][0-9]{6}|[0-9]{2}[A-Za-z][0-9]{6})$"
Local $sString = "Length 7 or 9 First character must be a letter a-z or A-Z if number of characters are 7 The remaining 6 must be numeric 0-9 example" & @CRLF & _
"" & @CRLF & _
"a555444" & @CRLF & _
"B999999" & @CRLF & _
"" & @CRLF & _
"Third character must be a letter a-z or A-Z if number of characters are 9 The remaining 8 must be numeric 0-9" & @CRLF & _
"" & @CRLF & _
"example" & @CRLF & _
"" & @CRLF & _
"12B456789" & @CRLF & _
"16K456745" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")