const regex = /^([A-Za-z][0-9]{6}|[0-9]{2}[A-Za-z][0-9]{6})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z][0-9]{6}|[0-9]{2}[A-Za-z][0-9]{6})$', 'gm')
const str = `Length 7 or 9 First character must be a letter a-z or A-Z if number of characters are 7 The remaining 6 must be numeric 0-9 example
a555444
B999999
Third character must be a letter a-z or A-Z if number of characters are 9 The remaining 8 must be numeric 0-9
example
12B456789
16K456745
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}